Vultr.com - Instant Cloud Server Deployment
GAMETRACKER FORUMS
Forum Home > General Help > SSL issues for GT subdomains
overclockedlanPM
#1
SSL issues for GT subdomains
Apr 17, 2017 7:47 PM
Joined: Oct 16, 2013
Posts: 7
This poses an issue for websites that display GameTracker banners and utilize an SSL/https connection.

For example:
https://overclockedlan.pro/servers.php

As you can see, I have maps disabled on these banners. The reason being, https://image.gametracker.com/images/maps/160x120/kf2/kf_containmentstation.jpg

In addition, when browsing GameTracker on an https connection:
https://www.gametracker.com/server_info/206.221.188.26:7777/

You will see here that since an SSL is not attached to these GT subdomains, images do not appear on the page (group/map).

If a website owner does not force https:// in GameTracker banners and related embed codes, it breaks that pages SSL for them. e.g. if I embed the userbar size banners on my forum home page (which I do); I must edit the embed code to use all https:// links as it would otherwise break my SSL for that entire page, and it is referenced in the JS console.

Your Google AdSense ads also do not display on your https pages.
burnPM
#2
Apr 17, 2017 8:27 PM
GAMETRACKER ADMIN Joined: Sep 27, 2006
Posts: 10779
Since GameTracker does not currently support HTTPS, this make sense.
Please check periodically in the future.
@Vultr Cloud - Try it out with Free Credit

I am a community user.
Note: I neither read nor reply to PMs asking for support. Please use the forums for questions.

Reporting abuse | Guides & FAQ
overclockedlanPM
#3
Apr 17, 2017 10:11 PM
Joined: Oct 16, 2013
Posts: 7
I thought that might be the case, however it was to my surprise that when I figured out I must edit the code to https:// - and browsed GameTracker on a secure encryption, it was not throwing me invalid SSL errors, so I went with it.

I don't really have a choice if I want to embed them on a secure page.
Will keep tabs. Thanks

In addition, for some reason on the forums in https://, your avatar shows, but mine doesn't. Perhaps it's just in my cache or something. Furthermore however, you can not enter a secure URL in team settings. It is forced http://

Sorry if I'm being too nit-picky, but I'm sure this has posed an issue for a lot of people in the past that utilize a secure encryption on their websites and want to use GT banners, but instead move to custom modifications such as LGSL and what not.

My problem with that is it doesn't do what I want it to do, and I don't want to manually enter a game again (KF2) since a data wipe that I had. I'd rather give in to GT premium much like I have in the past. The extra location comes in handy.
Last edited by: overclockedlan Apr 17, 2017 10:22 PM